Докуметация Cтарт Статьи Форум Лента Вход
Не официальное русскоязычное сообщество
Главная
    Документация jMonkeyEngine
        jMonkeyEngine Уроки и Документация
            Документация для продвинутых пользователей
                MakeHuman Blender OgreXML Набор инструментов для создания и импорта анимированных персонажей человека

MakeHuman Blender OgreXML Набор инструментов для создания и импорта анимированных персонажей человека

Опубликованно: 11.05.2017, 23:03
Последняя редакция, Andry: 29.09.2017 19:06

В этом руководстве описывается использование инструментальной цепи MakeHuman Blender OgreXML.

Инструменты

Последние версии на момент написания:

  • MakeHuman: 1.0.2
  • Blender: 2.72
  • OgreXML экспортер для Blender: 0.6.0

Инструменты можно загрузить со следующих URL-адресов:

Seed Project

Общественное достояние Seed Project с некоторыми заданными персонажами и анимацией:

Подготовка

  1. Установите MakeHuman и Blender.
  2. Установите импортер MakeHuman Blender из установки MakeHuman в папку скриптов Blender и включите скрипт из Blender File → User Preferences → Дополнения.
  3. Установите OgreXML exporter в папку сценариев Blender и включите сценарий из Blender File → User Preferences → Addons.
  4. Клонируйте seed project или создайте свой собственный проект.
  5. Найдите или создайте папку модели персонажа (src/main/resources/character/human/female)

Создание модели персонажа с помощью MakeHuman

  1. Создайте модель персонажа с помощью MakeHuman. ([http://www.makehuman.org/documentation])
    • ПРИМЕЧАНИЕ. Если вы хотите использовать анимации JME3 Open Asset Pack без настройки, используйте либо male.mhm, либо female.mhm в качестве предустановки и не меняйте пропорции тела.
  2. Выберите базовы скелет из вкладки «Pose»/«Animate», если вы еще не используете какие-либо из предустановок.
  3. Экспорт в формат обмена blender из вкладки Files → Export.
    • Выберите «Mesh Format» → «Blender exchange».
    • Отметьте только Options → Feet на земле и масштабные Units → Meter

Анимационная модель персонажа с Blender

  1. Импортируйте модель персонажа в формат обмена blender (MHX) в Blender или откройте файл preset blender в файле female.blend.
  2. Если вы используете свой персонаж, вы можете добавлять анимации из файлов male.blend или female.blend с помощью Blender File → Append. Анимации находятся в папке animation.
  3. Настройте модель model / materials и оживите персонажа. ([Http://www.blender.org/support/tutorials/])

Экспорт модели персонажа из Blender в Ogre XML

  1. Убедитесь, что ваши объекты сцены в Blender не имеют пробелов или специальных символов в именах. Переименуйте их, если они есть.
  2. Организуйте все ваши анимации в одной дорожке NLA один за другим без наложений или касания на временной шкале.
  3. Отмените связь анимаций, связанных непосредственно с вашей armature персонажа или сеткой.
  4. Экспорт с помощью Blender → File → Export Ogre3D (сцена и сетка) и отметьте следующие варианты:
    • copy shader programs(Копировать шейдерные программы)
    • Export Scen(Экспортировать сцену)
    • Export Meshes(Экспортировать сетки)
    • Export Meshes (overwrite)(Экспортировать сетки (перезаписывать))
    • Armature Animation
    • Optimize Arrays(Оптимизировать массивы)
    • Export Materials(Экспортировать материалы)
    • Tangents
    • Reorganize Buffers(Реорганизовать буферы)
    • Optimize Animations(Оптимизация анимации)

Импорт Ogre XML в JME3

Вы можете загрузить XML-файл ogre с помощью менеджера ресурсов или импортировать их в SDK и, последовательно, преобразовать их в формат ресурсов JME3.

Вы можете протестировать анимацию, создав собственную версию AnimationPreviewer:

AnimationPreview.java


Переведено для jmonkeyengine.ru, оригинал
Автор перевода: Andry

Добавить комментарий

jMonkeyEngine.ru © 2017. Все права сохранены.