Докуметация Cтарт Статьи Форум Лента Вход
Не официальное русскоязычное сообщество
Главная
    Документация jMonkeyEngine
        jMonkeyEngine SDK: Документация
            Сборка jMonkeyEngine SDK самостоятельно

Сборка jMonkeyEngine SDK самостоятельно

Опубликованно: 06.10.2017, 21:06
Последняя редакция, Andry: 10.10.2017 18:56

В jMonkeyEngine SDK или NetBeans

Плагины

Убедитесь, что все необходимые плагины установлены и активны:

  • В строке меню выберите Сервис ▸ Подключаемые модули, чтобы открыть диалоговое окно Подключаемые модули.
  • Перейдите на вкладку Доступные подключаемые модули.
  • Отсортируйте список плагинов по категориям.
  • Установите галочку для установки, всем плагинам в категории Developing NetBeans.
  • Нажмите кнопку [Установить] и установите их с помощью мастера.
  • Выберите вкладку Установлены.
  • Активируйте любые неактивные плагины в категории Developing NetBeans.
  • Закройте диалоговое окно Подключаемые модули.

Проверка

  • В строке меню выберите Группа ▸ Git ▸ Клонировать, чтобы открыть диалоговое окно Clone Repository.
  • В URL-адрес репозитория: текстовое поле введите https://github.com/jMonkeyEngine/jmonkeyengine.
  • Очистите текстовые поля Пользователь: и Пароль:.
  • Нажмите кнопку [Далее].
  • Выберите удаленную ветвь, как правило, master и нажмите кнопку [Далее].
  • Нажмите кнопку [Обзор] справа от текстовое поля относящегося к Родительский каталог:, чтобы открыть диалоговое окно Выбор родительского каталога.
  • Выберите пустой или несуществующий каталог (папку), где вы хотите сохранить исходники jMonkeyEngine на своем жестком диске.
  • Нажмите кнопку [Готово].

Проверка проекта может занять некоторое время. Не выполняйте никакие действия до завершения задачи.

Сборка

В командной строке:

  1. cd jmonkeyengine
  2. ./gradlew build

Из SDK:

  • В строке меню выберите Файл ▸ Открыть проект…, чтобы открыть диалоговое окно Открытие проекта.
    • Выделите папку проекта в свободной форме, которую вы использовали для проверки, и нажмите кнопку [Открыть проект].
  • Новый проект в свободной форме с именем jME3-SDK должен появиться в окне Проекты в SDK.
  • Создайте проект свободной формы, щелкнув его [ПК мыши] и выбрав Собрать проект.
  • Подождите, пока задача jME3-SDK (build) не будет завершена. В какой-то момент можно открыть окно веб-браузера.
  • В строке меню выберите Файл ▸ Открыть проект…, чтобы открыть диалоговое окно Открытие проекта.
  • Перейдите в папку проекта в свободной форме, выделите узел sdk и нажмите кнопку [Открытие проекта].
    • В окне Проекты в SDK появится ряд новых проектов.

Сборка основного проекта в свободной форме копируют библиотеки jME3 в sdk, поэтому вы должны запускать скрипт сборки каждый раз, когда изменяется jME3.

Запуск

  • В окне Проекты в SDK щелкните [ПК мыши] проект jMonkeyEngine SDK и выберите Выполнение.
      SDK, который вы только что создали, начнет работать в новом окне.

Переведено для jmonkeyengine.ru, оригинал
Автор перевода: Andry

Добавить комментарий

jMonkeyEngine.ru © 2017. Все права сохранены.