Докуметация Cтарт Статьи Форум Лента Вход
Не официальное русскоязычное сообщество
Главная
    Документация jMonkeyEngine
        jMonkeyEngine SDK: Документация
            jMonkeyEngine SDK: Редактор кода и Палитра

jMonkeyEngine SDK: Редактор кода и Палитра

Опубликованно: 30.04.2017, 20:22
Последняя редакция, Andry: 16.11.2017 17:36

Редактор исходного кода является центральной частью jMonkeyEngine SDK. В этой документации вы узнаете, как максимально использовать вспомогательные функции jMonkeyEngine SDK.

Поскольку jMonkeyEngine SDK основан на платформе NetBeans, вы можете узнать о некоторых функциях SDK jMonkeyEngine, прочитав соответствующие руководства по среде IDE NetBeans (см. Также ссылки).

Автозаавершение кода и генерация кода

При вводе кода Java в редакторе исходного кода вы увидите всплывающие окна, которые помогут вам быстрее писать, заполнять ключевые слова и генерировать фрагменты кода. Кроме того, они позволят вам увидеть javadoc для классов, с которыми вы работаете.

netbeans_code_completion

Автозавершение кода

  • Полное ключевое слово / метод / переменная: Ctrl+Space Также вы можете использовать Ctrl+\.
    • Настройка параметров автозавершения кода: Сервис ▸ Параметры ▸ Редактор ▸ Автозавершение кода
  • Показать ожидаемые параметры этого метода в подсказке: Ctrl+P
  • Заполнить любую строку (даже не-Java), которая использовалась ранее: (Shift+)Ctrl+K

Генерация кода

  • Автоматическое исправление операторов импорта: Ctrl+Shift+I
  • Автоматическое создание геттеров / сеттеров, try / catch, equals / hashCode: Alt+Insert
    • Настройка шаблонов кода. Выберите Сервис ▸ Параметры ▸ Редактор ▸ Автозавершение кода.
  • Автоматически создавать общие фрагменты кода, такие как циклы, объявления, println, введя имя шаблона + Tab
    • Настройка шаблонов кода. Выберите Сервис ▸ Параметры ▸ Редактор ▸ Шаблоны кода.
  • Переименование, перемещение или введение методов, полей и переменных без нарушения проекта: меню Реорганизация кода

Семантическая и синтаксическая подсветка

jmonkeyplatform-docu-5

Цвет текста в редакторе дает вам важные подсказки, как компилятор будет интерпретировать то, что вы набрали, даже до того, как вы его скомпилировали.

Примеры:

  • Ключевые слова Java — синие, переменные и поля — зеленые, параметры — оранжевые.
  • Зачеркивание означает устаревший метод или поле.
  • Серое подчеркивание означает неиспользованная переменная или метод.
  • Поместите каретку в методе или переменной, и все ее вхождения будут отмечены как затенённым.
  • Поместите каретку в возвращаемом типе метода, чтобы выделить все точки выхода
  • И многое другое …

Чтобы настроить цвета и отступы:

  • Сервис ▸ Параметры ▸ Редактор ▸ Форматирование.
  • Сервис ▸ Параметры ▸ Шрифты и цвета.

Подсказки редактора и быстрые исправления (или лампочки)

Подсказки редактора и быстрые исправления отображаются в виде лампочек вдоль левого края редактора. Они указывают на предупреждения и ошибки, и часто предлагают полезные решения!

  • Выполните быстрое исправление: поместите курсор в строке рядом с лампочкой и нажмите AltEnter (или щелкните лампочку)
    • Настройка подсказок. Выберите Сервис ▸ Параметры ▸ Редактор ▸ Подсказки.

Javadoc

  • Поместите курсор над методом или классом, который не имеет Javadoc, введите
  • /**

    И нажмите Enter: Редактор генерирует скелетный код для комментария Javadoc.

  • Щелкните [ПК мыши] проект в окне Проекты и выберите Создать документацию Java.
  • Щелкните файл правой кнопкой мыши и выберите Инструменты ▸ Анализ Javadoc

Чтобы отобразить всплывающее окно javadoc в редакторе, поместите каретку в строку и нажмите Ctrl+Space (альтернативно используйте Ctrl+\).

  • Если всплывающее окно javadoc не работает, убедитесь, что
    • У вас установлена ​​и настроена документация Java JDK: Инструменты ▸ Платформы Java
    • Вы загрузили и настроили javadoc для сторонних библиотек: Свойства проекта ▸ Библиотеки ▸ Изменить

Навигация по исходникам jME3

Когда JavaDoc не предоставляет достаточную информацию, вы можете посмотреть исходник каждого метода или объекта jME3, который вы используете. Просто щелкните правой кнопкой мыши по переменной или методу, выберите Переход ▸ Перейти к исходному файлу и редактор откроется, показывая вам исходный файл jME3.

Палитра

jmonkeyplatform-docu-4

Выберите Окно ▸ IDE и сервис ▸ Палитра, чтобы открыть контекстно-зависимую Палитру. JMonkeyEngine SDK предоставляет вам фрагменты кода jme3, которые можно перетаскивать в ваши исходные файлы.

Примеры: фрагменты кода для создания Узлов и Моделей.

В меню выберите Инструменты ▸ Добавить в подсветку …, чтобы добавить свои собственные фрагменты кода в подсветку. (Пока недоступно в бета-версии)

Горячие клавиши

  • Переход к файлу: Alt+Shift+O
  • Перейдите к Типу: Ctrl+O
  • Открыть окно Проекты / Файлы / Избранное: Ctrl+Shift+1/2/3
  • Сборка и запуск основного класса проекта: F6
  • Переключиться в редактор / Проекты / Файлы / Навигатор: Ctrl+0/1/3/7
  • Отступ кода: Ctrl+Shift+F

По умолчанию jMonkeyEngine использует те же ярлыки редактора, что и среда IDE NetBeans, но вы также можете переключиться на Eclipse Keymap или создать свой собственный набор.

  • Настройка быстрых клавиш: Сервис ▸ Параметры ▸ Назначение клавиш

Советы и приемы

  • Чтобы просмотреть физическую структуру своего проекта, используйте окно Файлы: Ctrl+2
  • Чтобы открыть файл, который не является частью проекта Java, добавьте его в окно Избранное: Ctrl+3
  • Если вы не можете найти конкретный пункт меню или панель опций, используйте поле Поиск в IDE в верхнем правом углу! Ctrl+i
  • Если блок кода, класс или javadoc достаточно длинный и вы не хотите его прокручивать, щелкните значок +/-, чтобы временно свернуть блок.
  • Нажмите F1 для справки.

Смотрите также:

Переведено для jmonkeyengine.ru, оригинал.
Автор перевода: AdiDOS

Добавить комментарий

jMonkeyEngine.ru © 2017. Все права сохранены.