Докуметация Cтарт Статьи Форум Лента Вход
Не официальное русскоязычное сообщество
Главная
    Документация jMonkeyEngine
        jMonkeyEngine SDK: Документация
            jMonkeyEngine SDK: Создание проекта

jMonkeyEngine SDK: Создание проекта

Опубликованно: 30.04.2017, 13:12
Последняя редакция, Andry: 26.06.2017 19:28

jMonkeyEngine SDK делает легким начало разработки 3D — игры на базе jMonkeyEngine.

Создание нового проекта в jMonkeyEngine

  1. Выберите Файл > Создать проект в главном меню
  2. В мастере создания проекта, выберите шаблон JME3 > Basic Game
  3. Кликните [Далее], чтоб задать имя, и директорию для сохранения проекта.
  4. Кликните [Готово]. Создастся скелет приложения и откроется в Проекты.
    • Это базовое приложение jme3 основное на классе SimpleApplication который позволяет легко начать работу с jme3.
    • Вы можете нажать кнопку Запустить проект, чтоб собрать проект, и вы увидите куб jMonkey.

Структура проекта

Давайте взглянем на абстрактную структуру проекта в Проекты (ctrl1).

  1. Узел Project Assets: эти директории созданы для хранения контента ваших игр, таких как шрифты, материалы, модели, шейдеры, звуки и текстуры. Для вновь созданного проекта эти директории пусты.
  2. Узел Пакеты исходных кодов: Здесь вы управляете своими пакетами и классами. Для нового созданного проекта он содержит один пакет и один класс Main.java. Дважды нажмите Main.java, чтобы открыть его в редакторе.
  3. Узел Библиотеки: Обзор всех путей для хранилищ библиотек к вашей игре. Путь к классам уже настроен для инфраструктуры jme3 (включая LWJGL, Bullet, Nifty GUI и т. д.).

Структура директории

Теперь давайте посмотрим на структуру файлов проекта в Файлы (ctrl2). Этот проводник показывает физическую структуру директорий на вашем жестком диске.

  • Assets — этот директория соответствует узлу Project Assets. Это необходимо для assetManager. Это рекомендуемая внутренняя структура:
    • assets/Interface
    • assets/MatDefs
    • assets/Materials
    • assets/Models
    • assets/Scenes
    • assets/Shaders
    • assets/Sounds
    • assets/Textures
  • Src — этот директория соответствует узлу Source Packages. Здесь находится исходный код.
  • Nbproject — это метаданные, используемые jMonkeyEngine SDK (не редактировать).
  • Build.xml — это скрипт сборки Ant, который подключается к действиям clean / build / run / test в SDK jMonkeyEngine. Он загружает скрипт построения по умолчанию и позволяет вам дополнительно настраивать процесс сборки. Скрипт Ant также гарантирует, что вы сможете очищать / создавать / запускать / тестировать ваше приложение за пределами jMonkeyEngine SDK — например. Из командной строки.
  • Build — Этот каталог содержит скомпилированные классы. (Будет сформирован SDK jMonkeyEngine при создании проекта.)
  • Dist — этот каталог содержит исполняемые JAR-файлы. (Будет сформирован SDK jMonkeyEngine при создании проекта.)
  • test – SDK jMonkeyEngine будет хранить тесты JUnit здесь, если вы их создадите. (Дополнительно.)

Конфигурация проекта

Щелкните [ПК Мыши] проект, чтобы открыть свойства проекта.

  • В разделе Выполнение укажите Главный класс вашего проекта. (Нажатие F6 запускает этот основной класс.)
  • В разделе Выполнение вы можете дополнительно настроить параметры JVM и параметры командной строки.
  • В разделе Приложение укажите название игры заголовок (по умолчанию игра будет называться BasicGame).
  • В разделе Приложение укажите название поставщика (ваше имя), краткое описание, домашнюю страницу своего проекта и заставку.

Очистка, построение и запуск цикла

jmonkeyplatform-docu-5

Нажатие F6 создает и запускает основной класс основного проекта. Если есть несколько классов или несколько проектов, вы должны указать, какой из них вы хотите запустить F6. Щелкните проект [ЛК мыши] и вы выберите этот проект в качестве основного проекта, затем щелкните этот проект [ПК мыши] и выберите Свойства > Выполнение и укажите Главный класс что бы при нажатии F6 запускался нужный вам класс.
Чтобы собрать и запустить main() любого файла класса, открытого в редакторе, нажмите ShiftF6!
  • Щелкните [ПК мыши] проект и используйте контекстное меню, чтобы очистить все сгенерированные классы и JAR.
  • Щелкните [ПК мыши] отдельные файлы с основным методом их соберите и запустите их. (ShiftF6)
  • Нажмите кнопку Запустить проект (зеленая стрелка на панели инструментов), чтобы создать и запустить проект. (F6)

Открыто более одного проекта? Кнопки панели инструментов и F-клавиши привязаны к основному проекту, который выделен жирным шрифтом в Проекты. Щелкните проект правой кнопкой мыши и выберите «Установить как главный проект», чтобы он реагировал на кнопки панели инструментов и клавиши F.

Обеспокоены необходимость SDK? Вы никогда не привязаны к jMonkeyEngine SDK: в любой момент вы можете изменить свой каталог проекта в командной строке, а также очистить, построить и запустить ваш проект, используя непатентованные команды Apache Ant: ant clean; ant jar; ant run;

Процесс разработки

  • Создание новых файлов и пакетов: Выберите узел Пакеты исходных кодов (или любой из его подузлов) и нажмите ctrlN (Файл → Создать файл): с помощью мастера создания файлов создайте новые классы Java, пакеты Java, Java-компоненты, формы Swing , JUnit файлы, j3m Материалы, j3o сцены, j3f фильтры и многое другое.
  • Редактирование файлов. Откройте Проекты и дважды щелкните файл Java из узла Пакеты исходных кодов, чтобы открыть его в редакторе. Редактор кода jMonkeyEngine SDK помогает во многих отношениях, включая синтаксическую и семантическую окраску кода, завершение кода и javadoc.
  • Добавление ресурсов(Assets):
    • Вы можете импортировать модели, сцены и материалы в качестве игровых ресурсов в свой проект.
    • Чтобы добавить звуковые файлы и изображения, используйте проводник файлов операционной системы и скопируйте файлы в каталог asset вашего проекта.
  • Список задач. Окно задач автоматически отображает все строки, содержащие ошибки и предупреждения, а также все строки, которые вы пометили ключевыми словами комментария.
  • FIXME, @todo, or TODO.

Добавление внешних библиотек jar

Вы можете использовать внешние Java-библиотеки в своем проекте jME, например, генераторы контента или реализации искусственного интеллекта.

Добавьте библиотеку в список глобальных библиотек:

  • Выберите Сервис → Библиотеки в главном меню.
  • Нажмите [Создать библиотеку], введите имя библиотеки и нажмите [ОК].
  • На вкладке Путь к классам нажмите [Добавить файл JAR/папку…] и выберите файл(ы) jar, необходимый для библиотеки
  • (Дополнительно) На вкладке Документация JavaDoc нажмите [Добавить архив ZIP или папку…] и выберите javadoc для библиотеки, в виде zip-файла или папки.
  • (Дополнительно) На вкладке Исходные файлы вы можете выбрать папку или файл jar, содержащий исходные файлы библиотеки.
  • Нажмите [OK]

Добавьть библиотеку в проект:

  • Щелкните [ПК мыши] свой проект и выберите Свойства.
  • Выберите Библиотеки слева и нажмите [Добавить библиотеку]
  • Выберите библиотеку из списка и нажмите [OK].

Вот и все, ваш проект теперь может использовать внешнюю библиотеку. Если вы также связали javadoc и источники, SDK поможет вам с javadoc-всплывающими окнами, кодом завершения (ctrlspace) и исходной навигацией (ctrl-click).

Развертывание приложений

  • Вы можете развернуть игру в качестве настольного приложения (JAR), браузер апплет, WebStart (JNLP), или на Android платформе.

Выполнение примеров проектов

В SDK содержится примеры кода (подробнее).

Откройте узел Пакеты исходных кодов проекта JmeTests.

  • Щелкните [ПК мыши] проект JME3Tests и выберите Выполнить. Выберите образцы в TestChooser и попробуйте демонстрационные примеры.
  • Просмотрите исходный код демоверсии в окне проекта SDK, чтобы узнать, как функция реализована и используется.
  • Не стесняйтесь изменять образцы кода и экспериментировать! Если вы что-то сломаете, вы всегда можете воссоздать упакованные образцы из шаблона JME3 Tests. Просто создав заново проект по шаблону JME3 Tests

Переведено для jmonkeyengine.ru, оригинал.
Автор перевода: AdiDOS

Добавить комментарий

Содержание

jMonkeyEngine.ru © 2017. Все права сохранены.