Докуметация Cтарт Статьи Форум Лента Вход
Не официальное русскоязычное сообщество
Главная
    Документация jMonkeyEngine
        jMonkeyEngine SDK: Документация
            jMonkeyEngine SDK: Примеры кода

jMonkeyEngine SDK: Примеры кода

Опубликованно: 16.06.2017, 18:51
Последняя редакция, Andry: 07.10.2017 14:00

Вы можете запустить пример кода, открыв включенный в jME проект JME3Tests и добавив в него игровые ресурсы(asset). Вы также можете выполнить поиск встроенной документации или перетащить фрагменты кода из палитры в SDK, чтобы получить образец короткого кода.

Палитра кодов и примеры в SDK

  • Введите ключевое слово в поле поиска в SDK или нажмите F1, чтобы найти встроенную справку для примера кода.
  • Редактор кода SDK и Палитра

Шаблон проекта JME3Tests

jMonkeyEngine SDK содержит тестовый проект с большим количеством примеров кода и игровых ресурсов. Тестовый проект настроен и готов к запуску, и его легко использовать для новичков (нет необходимости возиться с классами или библиотеками).

  1. Установите и откройте jMonkeyEngine SDK.
  2. Перейдите в Файл ▸ Создать проект.
  3. В мастере создания проекта в категории JME3 выберите JME3 Tests. Нажмите [Далее].
  4. Укажите расположение, например создайте каталог jMonkeyProjects в своем домашнем каталоге. Нажмите [Готово].

Этот шаблон проекта по умолчанию создает проект под названием JmeTests. Он содержит все тестовые классы и примеры из исходного хранилища jme3. Не стесняйтесь изменять образцы кода и экспериментировать! В маловероятном случае, когда вы должны сломать проект, 😉 вы всегда можете воссоздать все упакованные образцы, создав еще один проект из шаблона JME3 Tests в мастере создания проекта.

Если вы используете текущую версию SDK версии 3.1.0-Stable, вам необходимо установить формат исходного/бинарного файла: из окна Свойства проекта на Java 1.7 или новее.

  • Чтобы изменить исходный формат, кликните [ПК Мыши] по jmeTestProject, а затем выберите Свойства ▸ Исходные файлы ▸ формат исходного/бинарного файла: или в меню «Файл», с выделенным jmeTestProject, Файл ▸ Свойства (jmeTestProject) ▸ Исходные файлы ▸ формат исходного/бинарного файла:.

Вам также потребуется удалить библиотеку jme3-jbullet и добавить jme3-bullet и jme3-bullet-native библиотеки.

  • В окне Свойства проекта выберите Библиотеки, а затем вкладку Компилировать. В библиотеке компиляции выберите jme3-jbullet и нажмите [Удалить]. Нажмите [Добавить библиотеку], выберите две библиотеки jme3-bullet и jme3-bullet-native, удерживая Ctrl, а затем нажмите [Добавить библиотеку] и, наконец, [ОК].
Нажмите Shift + F6, чтобы выполнить класс, выбранный в редакторе, или [ПК Мыши] класс в окне Проекты и выберите [Выполнить файл]. Вы можете запустить приложение TestChooser [ПК Мыши], выбрав проект и нажав [Выполнить]. Приложение TestChooser позволяет легко перемещаться по всем тестовым сценариям.

JME3TestData Игровые ресурсы(Assets)

Вы можете получить доступ к некоторым образцам игровых ресурсов, таким как 3D-модели или текстуры, в одном из ваших проектов. Общей ситуацией для этого было бы, пройти через обучающие программы для начинающих.

  1. [ПК Мыши] выберите существующий проект jME3 в SDK и выберите [Свойства].
  2. В окне Свойства проекта выберите раздел Библиотеки. Перейдите на вкладку Компилировать, она содержит Библиотеки этапа компиляции.
  3. Нажмите кнопку [Добавить библиотеку] и выберите предопределенные данные jme3-test. Нажмите [ОК].
  4. Нажмите [ОК], чтобы сохранить и закрыть Свойства проекта.

Теперь assetManager проекта имеет доступ к файлам примерам из файла jme3-test-data.jar. Эта библиотека JAR содержит

  • Модели Ogre XML: Ninja.mesh.xml, Oto.mesh.xml, HoverTank.mesh.xml, Sinbad.mesh.xml и многие другие.
  • Blender модели
  • Материалы и Текстуры
    • Ландшафт, небо, скала, кирпич, пруд…
    • Текстуры эффектов частиц
  • Звуки
  • И другое…

AssetPacks

assetpackbrowser-300x166

Если вам нужны образцы трехмерных моделей, не упустите возможность скачать наши Asset Packs, предоставленные сообществом!

В SDK:

  • Откройте AssetPackBrowser из меню Окно
  • В AssetPackBrowser нажмите кнопку Online AssetPacks
  • Нажмите [Install] на AssetPack по вашему выбору. SDK загружает его и делает доступными игровые ресурсы в вашей библиотеке AssetPack.
  • Нажмите кнопку [View Library] и откройте узел «Asset».
  • [ПК Мыши] выберите asset для
    • Предварительного просмотра
    • Добавления в SceneComposer
    • Добавления в проект игры в папку assets

Узнайте больше об Asset Packs и о том, как вы можете поделиться своей коллекцией с сообществом.


Переведено для jmonkeyengine.ru, оригинал
Автор перевода: Andry

Добавить комментарий

jMonkeyEngine.ru © 2017. Все права сохранены.