Докуметация Cтарт Статьи Форум Лента Вход
Не официальное русскоязычное сообщество
Главная
    Документация jMonkeyEngine
        jMonkeyEngine SDK: Документация
            jMonkeyEngine SDK: Управление версиями

jMonkeyEngine SDK: Управление версиями

Опубликованно: 04.10.2017, 18:02
Последняя редакция, Andry: 06.10.2017 18:04

Независимо от того, работаете ли вы в команде разработчиков или в одиночку: Управление версиями файлов это удобный метод, чтобы поддерживать постоянство кода, сравнивать файлы по очереди и даже откатывать нежелательные изменения. В этой документации показано, как максимально использовать интегрированные в SDK возможности управления версиями для Subversion, Mercurial и Git.

Для каждого члена команды процесс управления версиями файлов выглядит следующим образом:

  1. Единожды: Загрузите рабочую копию проекта из репозитория («checkout»).
  2. Регулярно: Добавление собственных изменений в репозиторий («commit»).
  3. Регулярно: Загружать обновления сделанные другими пользователями из репозитория («update»).
Поскольку jMonkeyEngine SDK основан на платформе фреймворка NetBeans, вы можете узнать о некоторых функциях jMonkeyEngine SDK, прочитав соответствующие учебники по NetBeans IDE (в разделе «См. Также ссылку»).

Системы управления версиями

jMonkeyEngine SDK поддерживает различные системы управления версиями, такие как Subversion, Mercurial и Git. Независимо от того, какой из них вы используете, все они имеют общий пользовательский интерфейс.

Вы можете использовать управление версиями файлов самостоятельно или в команде. Преимущества в том, что вы можете отслеживать изменения (кто это сделал, когда и почему), вы можете сравнивать версии по очереди, вы можете отменить изменения в файлах и строках, объединить несколько изменений в одном файле, и вы можете даже восстановить файлы.

Создание репозитория (Загрузка)

Требования:

  • У вас должен быть проект, нужной вам версии.
  • Необходимо установить программное обеспечение контроля версий (Subversion, Mercurial или Git) и инициализировать репозиторий.
    • Например, для Subversion команда инициализации выглядит следующим образом: svnadmin create /home/joe/jMonkeyProjects/MyGame
  • Компьютер, на котором размещается репозиторий, должен быть доступен в сети для вашей команды, иначе вы сможете использовать свой репозиторий только локально.
    • Хосты, такие как SourceForge, GoogleCode, dev.java.net, предлагают бесплатные службы контроля версий для проектов с открытым исходным кодом.

Теперь вы создаете репозиторий для хранения файлов вашего проекта.

  1. В jMonkeyEngine SDK щелкните [ПК мыши] проект в окне Проекты и выберите Управление версиями ▸ Импортировать в репозиторий Subversion(или выполните инициализацию Mercurial Project и.т.д.).
    • Если вы еще не определились, какую систему выбрать, начните с Subversion на данный момент.
  2. Пройдите мастер и заполните поля, чтобы настроить хранилище.

Проверка репозитория (загрузка)

Вы и ваши товарищи по команде проверяете (загружаете) хранилище на свои отдельные рабочие станции.

  1. Перейдите в меню Группа и выберите Subversion ▸ Checkout (или Git или Mercurial соответственно)
  2. Заполните ваши данные репозитория в мастер и нажмите «Готово».
    • Типичный URL-адрес репозитория выглядит следующим образом: http://jmonkeyengine.googlecode.com/svn/trunk/engine
    • Если вы хотите иметь возможность отправлять изменения, вы должны иметь имя пользователя и пароль в этом репозитории. В противном случае эти поля будут пустыми.
  3. Репозиторий загружается и сохраняется в выбранном вами месте.
  4. Используйте меню Файл ▸ Открыть проект, чтобы открыть checkout в качестве проекта и начать работу.
    • Если проверка не распознана, вам нужно выбрать Файл ▸ Создать ▸ Java ▸ Проект Java с существующими исходными файлами

Конечно, вы также можете проверить существующие репозитории и код доступный из других проектов с открытым исходным кодом (например, SourceForge, GoogleCode, dev.java.net).

Обновление и фиксация изменений (отправка и получение)

Получение последних изменений из репозитория команды называется updating. Отправка ваших изменений в репозиторий команды называется commiting.

  1. Перед внесением изменений щелкните [ПК мыши] проект и выберите Subversion ▸ Update, чтобы убедиться, что у вас есть последняя версия.
    • Регулярно обновляйтесь, прежде чем редактировать контрольную версией файлов. Это избавит вас от огорчений.
  2. После внесения изменений в проект убедитесь, что ваше изменение ничего не сломало в проекте.
  3. Обновление, сборка, запуск, тестирование.
  4. Посмотрите красные/зеленые/синие метки в редакторе, чтобы просмотреть, что вы удалили/добавили/изменили. кликните по метки, чтобы просмотреть все отличия файла.
  5. Выберите Subversion ▸ Show Changes, чтобы просмотреть все файлы, которые были недавно изменены — вами и другими членами команды.
  6. Обновите снова, на тот случай если ваши товарищи по команде внесли изменения в то время когда вы просматривали изменения.
  • Если конфликтов нет и вы хотите зафиксировать свои изменения, выберите в меню пункт Subversion ▸ Commit.
  • Напишите сообщение в commit, описывающее, что вы изменили.
    • Помните, вы пишете «сообщение себе на будущее». Никогда не пишите лишние вещи вроде «Я что-то изменил».
  • Сравнение и возврат изменений

    • Если вы и другой член команды отредактировали одну и ту же строку, возникает конфликт, и в jMonkeyEngine SDK появится сообщение об ошибке.
      • Щелкните файл [ПК мыши]. Выберите Subversion ▸ Resolve Conflict
        1. Сравните конфликтующие версии. Нажимайте кнопки, чтобы принимать или отклонять каждое изменение отдельно.
        2. После того, как resolver отобразит зеленый цвет, сохраните разрешино.
        3. Собирайте и тестируйте на разрешение, обновляйте и commit(фиксируйте).
    • Щелкните [ПК мыши] файл и выберите Subversion ▸ History History.
      • Вы можете проверить историю файла и посмотреть, кто что изменил, почему и когда.
      • При необходимости вы можете откатить файл к более старой версии.
    • В общем, вы можете выбрать Subversion ▸ Diff для любого файла, чтобы увидеть две версии файла рядом друг с другом.

    Без контроля версий? История!

    Если вы не используете какой-либо контроль версий, вы можете, в определенной степени, отслеживать изменения в проектах.

    • Щелкните файл или каталог [ПК мыши] и выберите История, чтобы отображать или отменять изменения или удалять файлы.
    • Вы также можете выбрать любые два файла в окне Проекты и выбрать Инструменты ▸ Различия для их сравнения.
    • История работает только для файлов, отредактированных в проектах jMonkeyEngine SDK (для других файлов это не работает, например, в окне Избранное).

    Смотрите также:


    Переведено для jmonkeyengine.ru, оригинал
    Автор перевода: Andry

    Добавить комментарий

    jMonkeyEngine.ru © 2017. Все права сохранены.